Please refer to TemplateMonster Support for any issues surrounding TemplateMonster/TemplateTuning Themes – thanks, Jigoshop Team

Jigoshop Version 1.6.4 probs

gregorborsic's Avatar

gregorborsic

23 Apr, 2013 08:16 PM

HI there, I am having a bit of problems here for some reason I am getting the following error on my Jigoshop website:

Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘Jigoshop_Widget_Featured_Products’ does not have a method ‘flush_widget_cache’ in /home/bodyarmo/public_html/wp-includes/plugin.php on line 406
{result”:”success”,”redirect

I have just updated my store to latest version.

Any help or advice is appreciated.

  1. Support Staff 2 Posted by ivica on 23 Apr, 2013 08:23 PM

    ivica's Avatar

    Hi!

    1) You can turn OFF WordPress debugging:
    http://forum.jigoshop.com/kb/testings/how-to-turn-on-debug-testing-option
    or

    2) In case you don’t wan’t to do that, to install Jigoshop patch/update on
    gihtub (link below):
    https://github.com/jigoshop/jigoshop/archive/1.6.4.1.zip

  2. 3 Posted by gregorborsic on 23 Apr, 2013 08:27 PM

    gregorborsic's Avatar

    Thank you Ivica for fast replay. I am on it right now.

  3. Support Staff 4 Posted by ivica on 23 Apr, 2013 08:33 PM

    ivica's Avatar

    Good luck… these are Jigoshop Lead Developer advices.

  4. 5 Posted by jamblo on 23 Apr, 2013 09:20 PM

    jamblo's Avatar

    Oooooh. The 1.6.4.1 update SEEMS to work! Thanks for the swift response!

  5. Support Staff 6 Posted by ivica on 23 Apr, 2013 09:22 PM

    ivica's Avatar

    (happy face) 🙂

  6. 7 Posted by Gavin on 24 Apr, 2013 06:10 AM

    Hey I did the update and it’s destroyed my entire site, my admin access (blank screen). Tried deleting the plugin but still no luck. Also tried going back to older version and the 6.4.1 on git hub.

    Anyone else having these issues?

  7. 8 Posted by Gavin on 24 Apr, 2013 06:11 AM

    Hey I did the update and it’s destroyed my entire site, including admin access (blank screen). Tried deleting the plugin but still no luck. Also tried going back to older version and the 6.4.1 on git hub.

    Anyone else having these issues?

  8. 9 Posted by jecko on 24 Apr, 2013 08:16 AM

    hi , i ve the same problem as gregorborsic,
    how can i install the patch please?
    sorry i’m a noob …..

  9. 10 Posted by pdpk on 24 Apr, 2013 01:39 PM

    pdpk's Avatar

    Hello Ivica,
    I’m in the same situation. After the upgrade to 1.6.4 the same warning about line 406 display after the purchase in checkout page (in attachement the screenshot). All my website run very well. The only problem is after the purchase. Usually, the client was redirect to the thank you page, but not now and the page display the famous warning about the line 406. Another problem when the user have to refresh the checkout page to complete the purchase. In this case the checkout page nothing display, not form etc…so you have to leave and not complete the purchase.

    Question please: How we can come back please to normal situation. Normal situation means the user redirect after the purchase to the thank you page and if you have to refresh the page to display the checkout page.

    I have another shop with Jigotheme and everything run very well with 1.6.4

    Best Regards

    Mauro

Reply to this discussion

Internal reply

Formatting help or Preview

Attached Files

You can attach files up to 10MB

If you don’t have an account yet, we need to confirm you’re human and not a machine trying to post spam.