Issue with downloads over ~75 mb

Q: Downloadable products over ~75 MB are having issues with downloading. The file and its location are both correct and it’s verified by using smaller test files. When the file is larger, it downloads a 0 KB blank file instead.
Is this a Jigoshop issue or a server issue?

A: This is a server issue and you need contact your Host company to adjust the max download size in the php.ini file.

Note:

There are 4 settings which can affect the maximum size of a file you can download, although none are explicitly called “max download size”. Those are:

  • post_max_size

The combined maximum size of all files you need to send. If you have X number of files to download the total filesize of the files must not exceed the post_max_size value.

  • max_input_time

Downloads are affected by script execution time. Try setting this to 0 (unlimited) or a higher number than 30 seconds (default) to see if it works.

  • upload_max_filesize

This is the filesize limit of each individual file. Chances are that if this is under 75mb, WordPress axed your upload at this value. Lets say its at 25 mb and you need a 75mb file. At 25mb the download is axed by WordPress. Detecting that the file is incomplete (and thus corrupt), WordPress clears the contents of the file, but retains it on the system (thus you are downloading a blank file).

  • memory_limit

PHP scripts have a memory limit and generally speaking this can prevent some downloads from working. Try slowly increasing this value if you find that downloads still aren’t working.