Images not displaying on secure server https

Q: I’m having an issue with images not displaying on my website when viewed as https. I contacted my host and received the reply below. Has anyone got any ideas how to resolve this?

“I do apologize for not mentioning before that I set the setting for your upload path to wp-content/uploads/ for you. Your WordPress installation is ok and is correctly serving your images when I go to https://cheapoz.com.au. However I do see missing images on the page that are coming directly from your jigoshop plugin. I looked a the current settings for jigoshop and do not see any settings to define https:// directly Unfortunately beyond basic troubleshooting the plugin is beyond our scope of support. You will need to contact jigoshop to resolve this issue.”

A: Check if you have link protection enabled in Cpanel that prevent some images from displaying.