Cart is Empty

Tina Chapman

10 Feb, 2013 05:04 PM

Nothing is getting added to my cart. Just says "Your Cart is Empty"

I am using the Responsive theme which indicates it is compatible with Jigoshop. I also switched to Twenty Ten to see if it would help but did not. Enabled Debugging and this line shows up:

Warning: session_start(): open(/var/php_sessions/sess_ba371826d12d4a60d2e22596e6d3d88e, O_RDWR) failed: No such file or directory (2) in /hermes/bosoraweb071/b572/ipw.johnsonsportside/public_html/wp/wp-content/plugins/jigoshop/classes/jigoshop_session.class.php on line 20

Here is the System Info displayed in Jigoshop:
Multi-site: No

SITE_URL:                 http://www.johnsonsportside.com/wp
HOME_URL:                 http://www.johnsonsportside.com/wp
Jigoshop Version:         1.5.1
WordPress Version:        3.5.1
Platform:                 Windows 
Browser Name:             Firefox  
Browser Version:          18.0 
User Agent String:        Mozilla/5.0 (Windows NT 6.1; WOW 
                              64; rv:18.0) Gecko/20100101 Fire
                              fox/18.0
PHP Version:              5.3.13
MySQL Version:            5.0.91-log
Web Server Info:          Apache/2
PHP Memory Limit:         256M
PHP Post Max Size:        20M
WP_DEBUG:                 Enabled
WP Table Prefix:          Length: 3 Status: Acceptable
Show On Front:            page
Page On Front:            13
Page For Posts:           0
Session:                  Enabled
Session Name:             PHPSESSID
Cookie Path:              /
Save Path:                /var/php_sessions
Use Cookies:              On
Use Only Cookies:         On
UPLOAD_MAX_FILESIZE:      20MB
POST_MAX_SIZE:            20MB
WordPress Memory Limit:   40MB
WP_DEBUG:                 On
DISPLAY ERRORS:           On (1)
FSOCKOPEN:                Your server supports fsockopen.
ACTIVE PLUGINS:
Hide Title: 1.0.3
Jigoshop: 1.5.1
Meteor Slides: 1.5.1
Per Page Widgets: 0.0.7
Super Simple Google Analytics: 1.7.1
WordPress Backup to Dropbox: 1.4.3
WordPress SEO: 1.3.4.4
WP Wunderground: 1.2.5.1
CURRENT THEME:
Responsive Child Theme: 1.0.0

PLEASE HELP! Thank you!

  1. Support Staff 2 Posted by ivica on 10 Feb, 2013 05:13 PM

    ivica's Avatar

    If you performed all other following initial checkings of your web site /
    web shop, please post the results, the same goes for the Simple User
    testings (further below). From the error message it seems that is some host
    issue going on..

    - *update *your WordPress, Jigoshop plugin (and database - after Jigoshop
    update), Jigoshop extensions, XAMPP/MAMP (if installed on local PC) to the
    latest versions (if not done before)

    - *check your minimum server requirements *for Jigoshop plugin (
    http://forum.jigoshop.com/kb/getting-started/requirements) *
    **
    - deactivate (and uninstall, if needed) caching plugins, if any* (e.g. W3
    Total Cache or others)*

    - empty your browser cache + cookies* (e.g. using keyboard: CTRL + F5)*

    - quit and relaunch you browser / try other (different) browsers */ *try to
    recreate error on another PC*

    - *check the KB list of WordPress plugins not compatible with Jigoshop *(
    http://forum.jigoshop.com/kb/testings/list-of-wordpress-plugins-non-compatible-with-jigoshop
    )

    - *increase web site/WordPress memory *(
    http://forum.jigoshop.com/kb/faq/fatal-error-allowed-memory-size-of-xxxxx-bytes-exhausted-tried-to-allocate-xx-bytes-in-xx)
    and *PHP Post Max size*

    - check your *Jigoshop Extension requirements/documentation* (if the issue
    involves Jigoshop Extension).

    - try to think of *any customizations/changes* made on your web site /
    Jigoshop that could cause you issues in Jigoshop work

    - try to *delete/uninstall Jigoshop core plugin or/and Jigoshop extensions
    and reinstall them again

    *If nothing mentioned helps, in order to try to recreate reported issue,
    please write here detailed description what were you doing (step by step)
    and turn on debug testing option (
    http://forum.jigoshop.com/kb/testings/how-to-turn-on-debug-testing-option).
    Follow Jigoshop **Simple User testing procedure** on below link for
    particular problem (e.g. when you have checkout errors) or the whole
    procedure and post your debug.log file here so the developers can check out
    those errors:

    http://forum.jigoshop.com/kb/testings/simple-user-testing

    All of this is necessary to see if there is any bug in Jigoshop/extensions
    or if your issue is related only to your web site / web shop. Thx for your
    understanding.

  2. 3 Posted by Tina Chapman on 10 Feb, 2013 05:42 PM

    On Sun, Feb 10, 2013 at 11:13 AM, ivica <
    [email blocked]> wrote:

    I have looked at all of the issues you have recommended and everything
    looks good. There is one problem. I have deactivated Jigoshop and trying
    to Uninstall but it will not let me. I get this error - Fatal error: Class
    'jigoshop' not found in
    /hermes/bosoraweb071/b572/ipw.johnsonsportside/public_html/wp/wp-content/plugins/jigoshop/classes/jigoshop_options.class.php
    on line 546
    Before I enabled the Debugging it was a 500 server error. I would like to
    delete and start with a fresh install. How can I get rid of this? Thanks!

  3. Support Staff 4 Posted by ivica on 10 Feb, 2013 06:03 PM

    ivica's Avatar

    Do you still have 500 error?
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-internal-server-error-in-wordpress/

    If you can't uninstall Jigoshop using regular procedure (
    http://forum.jigoshop.com/kb/getting-started/uninstallation), than do it
    via FTP.

  4. Support Staff 5 Posted by chriscct7 on 10 Feb, 2013 09:52 PM

    chriscct7's Avatar

    Hi there,
    Your problem is not a Jigoshop one, nor a theme one, nor a plugin one.
    Its an issue with your host.

    Your original error said:
    Warning: session_start(): open(/var/php_sessions/sess_ba371826d12d4a60d2e22596e6d3d88e, O_RDWR) failed: No such file or directory (2) in /hermes/bosoraweb071/b572/ipw.johnsonsportside/public_html/wp/wp-content/plugins/jigoshop/classes/jigoshop_session.class.php on line 20

    This indicates that PHP session is not enabled properly on your host. Get in touch with their technical support. Tip with them, is not to hang up the phone till it is fixed. This is something a Sysadmin can fix relatively, though they may need to reboot the Apache server your site is running off of, so be ready for a long phone call

    Thats my best advice on the matter
    -Chris

  5. 6 Posted by Tina Chapman on 11 Feb, 2013 03:25 PM

    On Sun, Feb 10, 2013 at 3:53 PM, chriscct7 <
    [email blocked]> wrote:

    Thank you, I will do that. One thing I did do was deleted the Jigoshop
    folder because it would not uninstall in properly. I then also deleted all
    the pages that it created. I have now reinstalled Jigoshop to try again
    but none of the pages are there. Any way to get them back?

  6. Support Staff 7 Posted by chriscct7 on 11 Feb, 2013 03:50 PM

    chriscct7's Avatar

    You'll need to create them manually, insert the proper shortcodes, and then set the pages settings in Jigoshop settigns as needed:
    http://forum.jigoshop.com/kb/customize-jigoshop/shortcodes

  7. 8 Posted by Tina Chapman on 11 Feb, 2013 10:03 PM

    On Mon, Feb 11, 2013 at 9:50 AM, chriscct7 <
    [email blocked]> wrote:

    Thanks so much for all your help. I have everything working now and all we
    had to do was change the path for the PHPsessions.
    One last question - for all of the pages I have chosen the theme template
    of "full width no sidebar" but all of the pages have which lookds to be a
    left sidebar info underneath the jigoshop info. See
    www.johnsonsportside.com/wp/shop

    Thanks again!

  8. Support Staff 9 Posted by chriscct7 on 12 Feb, 2013 01:43 AM

    chriscct7's Avatar

    Thats correct. Jigoshop by default inserts a sidebar.

    You can remove it by placing the following in your theme's function.php file (if you go to Appearence->Editor, its a page on the right hand side.

    remove_action( 'jigoshop_sidebar', 'jigoshop_get_sidebar', 10);

Reply to this discussion

Internal reply

Formatting help or Preview

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.