Please refer to TemplateMonster Support for any issues surrounding TemplateMonster/TemplateTuning Themes – thanks, Jigoshop Team

Postcode validation

salocine

23 Aug, 2011 10:16 AM

Hi,

Using latest version, it seems that the Postcode validation (in uk) is not working properly.
The Jquery seem to “hang” (the animated gif constantly turning) and not allowing to submit the checkout form.
s

  1. Support Staff 2 Posted by Jeff on 23 Aug, 2011 01:32 PM

    Jeff's Avatar

    Ok, we haven’t had this report before. There have been a few other checkout issues, what indicates to you that is the postcode?

    Do you have a link?

    What version?

  2. 3 Posted by salocine on 23 Aug, 2011 01:39 PM

    Hi Jeff,
    thanks for coming back to me.
    Version is 0.9.8, sorry dont have a link as currently building.

    I am sure it’s the postcode validation as the loading gif/jquery issue only appears after entering a value in the postcode field, like it is checking for it indefinitely.

    S

  3. Support Staff 4 Posted by Jeff on 23 Aug, 2011 02:59 PM

    Jeff's Avatar

    All the jQuery validation code was removed in version 0.9.8.1 and so that may fix that problem. Unfortunately, a bug was introduced in the revised version for the Cart, in that you will have 0 for totals until the ‘Update Cart Totals’ button is clicked. If you don’t do anything, ignore the 0 totals and proceed to the Checkout, this will display properly.

    We are trying to look at a way of providing a quick fix for it, just don’t have it at the moment.

    If you want, you can upgrade with the latest public release:

    https://github.com/jigoshop/jigoshop

  4. 5 Posted by salocine on 23 Aug, 2011 03:15 PM

    Thx Jeff,

    so to clarify.
    0.9.8 has the Postcode jquery validation broken
    0.9.8.1 has the subtotal cart broken?

    Any idea of time frame for a fix on both?

    thx
    s

  5. Support Staff 6 Posted by Jeff on 23 Aug, 2011 05:58 PM

    Jeff's Avatar

    0.9.8 seems to have a problem for postcodes, for you. That may not be your problem and it is the first report of it.

    You could very well have something else at work, in fact I’m sure that you do, but without a link it will be hard to say.

    0.9.8.1 really only has a small issue and could clear up whether it’s a jQuery validation or something else.

    ‘Time Frame’ is soon. I’d like to say by the end of the month but refuse to commit to anything.

  6. Support Staff 7 Posted by Jeff on 23 Aug, 2011 06:38 PM

    Jeff's Avatar

    And, there is now a fix for the Cart subtotal problem, you could upgrade if you wish:

    https://jigoshop.com/topic/how-to-fix-cart-totals-for-version-0-9-8-1/

  7. 8 Posted by salocine on 30 Aug, 2011 09:28 AM

    Hi,

    I have now updated to the latest version at
    https://github.com/jigoshop/jigoshop

    The Sub total cart is indeed fixed, but I am still having problem with the postcode validation which seem to be , still, actif in the version above.

    Can you describe how to manually disable the validation and be able to proceed with the checkout process?

    thx

    S

  8. 9 Posted by salocine on 30 Aug, 2011 10:17 AM

    Postcode and County validation are not working on 0.9.8.2 (or latest version on github)
    To resolve this I have to disable the JQUERY check in jigoshop/assets/js/script.js.php

    Comment out lines 168,169,173,174
    and replace line 242 by
    jQuery(‘input#billing-country, input#shipping-country, input#shipping-state, #shipping-postcode’).live(‘keydown’, function(){

  9. 10 Posted by salocine on 13 Sep, 2011 05:11 PM

    my fault – solved

  10. Support Staff 11 Posted by Jeff on 13 Sep, 2011 06:16 PM

    Jeff's Avatar

    Ok. I’ll admit that preparations for final plugin release made me forgetful on this.

    Anything obvious?

  11. 12 Posted by salocine on 13 Sep, 2011 06:49 PM

    I had a copy of the checkout folder in my them folder, so certainly an old version overwriting the current checkout files.
    Deleting/updating to the latest file fixed the problem.

  12. 13 Posted by Ute on 16 Jan, 2012 05:16 PM

    Hello
    I have exactly the same problem:

    “The Jquery seem to “hang” (the animated gif constantly turning) and not allowing to submit the checkout form.”

    If I let my browser fill in the form automatically, everything works… (?!) The problem starts if I write the postal code with the keyboard…

    I upgraded my shop to Version 0.9.9.3.1, but still have the problem… Maybe I did something wrong when I wanted to restore the checkout-pay page? I have now only one version on this page, as far as I know…. Could you please help me with this comment:

    “I had a copy of the checkout folder in my them folder, so certainly an old version overwriting the current checkout files. Deleting/updating to the latest file fixed the problem.” I don´t know how to do this?”

    Thank you very much in advance!
    Ute

  13. Support Staff 14 Posted by Jeff on 16 Jan, 2012 05:37 PM

    Jeff's Avatar

    Well, there are a number of issues at work with this then. 0.9.9.3.1 is really not an upgrade.

    Try the manual upgrade instructions for the stable development branch of 0.9.9.4 RC2:

    http://forum.jigoshop.com/kb/getting-started/jigoshop-beta

    The spinning ajax is fixed as well as ability to have custom checkout templates either in a ‘jigoshop’ folder within your theme folder or the ‘checkout’ folder itself only, within your theme folder.

    There are changes to the form.php and review_order.php files however that you will have to incorporate into whatever you have for customizations. Take a look at them in jigoshop/templates/checkout and note the differences. (review_order.php is mostly just removal of all of the php code)

    If you don’t have your own customized checkout templates in your theme folder, then don’t worry about that comment.

  14. 15 Posted by ute on 16 Jan, 2012 06:17 PM

    Dear Jeff,

    thank you for your quick reply;) and sorry for the double posting.

    Great!! It works now! Thank you very very much!

    First I still had an issue in Chrome but after deleting the cache everything seems to work fine!

    Have a super happy week!
    Ute ;))

  15. 16 Posted by Martin on 26 Apr, 2012 06:24 PM

    Hi

    I have the spinning ajax in checkout. I have the last version of jigoshop

    Its not just confided to the postcode. If I fill in the form top to bottom it freezes on postcode and/or phone if I fill in from bottom to top it freezes on address fields.

    https://www.mpmw.co.uk/wpsite/buy

  16. 17 Posted by Martin on 27 Apr, 2012 10:29 PM

    OK an update on “spinning ajax in checkout”

    The domain that we had Jigoshop on has a SSL certificate. I copied over the Shop to our other domain that doesn’t… and it worked OK… no hanging in the checkout.

    I ran the the checkout page in Crome with the Dev Tools on and it gave this error about insecure data on page:

    XMLHttpRequest cannot load http://mpmw.co.uk/wpsite/buy1/wp-admin/admin-ajax.php. Origin https://mpmw.co.uk is not allowed by Access-Control-Allow-Origin.

    I have also tried it on Force SSL on in the setting checkout it hangs – same issue and I have tested Woo commerce and it has the same problem.

    So the question is it WordPress, the theme or Jigoshop? if its an Ajax issue is it more likely to be Jigoshop?

    Is it the case that most users are not running a SSL this issue is not that common? not that I am a techie but I think this issue is something on the Check out page form fields.

    If a Shopping cart cannot work within SSL then this is a big issue

Reply to this discussion

Internal reply

Formatting help or Preview

Attached Files

You can attach files up to 10MB

If you don’t have an account yet, we need to confirm you’re human and not a machine trying to post spam.