This is not good

liamiam

26 Jul, 2012 09:33 PM

Hi.

When I log in to the WP side as admin and I go to https://www.vihtavuori-lapua.com/wp-admin/admin.php?page=jigoshop_s...

I see this message:
Authorize.net is enabled and the force SSL option is disabled; your checkout is not secure! Please enable SSL and ensure your server has a valid SSL certificate.

again.... I am logged in as admin AND I have a valid SSL Cert. installed and it's properly configured.

When I click the link "force SSL option" it takes me to this page:

"https://www.vihtavuori-lapua.com/wp-admin/admin.php?page=settings"

and I get the message "You do not have sufficient permissions to access this page."

I'm lost here because as far as I know I have given myself the highest permission level one can have.

SO (and I am already really irritated about paying a tax for the extension and being told to "request a refund from Jiggo)
but we'll deal with that another time.

The NEXT thing I did was temporarily enable debug mode in WordPress, and was able to find the following errors specifically related to the Jigoshop plugin.

[26-Jul-2012 20:51:18] PHP Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/vihtavuo/public_html/wp-includes/functions.php:2628) in /home/vihtavuo/public_html/wp-content/plugins/jigoshop/classes/jigoshop_session.class.php on line 20

What do you think is wrong - and please don't tell me to try disabling other plugins or changing my theme to the default WordPress theme, I already tried that.

If there is something wrong - please tell me what it is.

Thank you.

-Liam

  1. Support Staff 2 Posted by ivica on 26 Jul, 2012 09:53 PM

    ivica's Avatar

    I found these discussions with the similar error message and possible
    solutions:

    http://forum.jigoshop.com/discussions/problems/1385-catalog-view-add-to-cart-button-on-variable-items-leads-to-blank-screen-wo-error-message

    http://forum.jigoshop.com/discussions/problems/3304-warning-session_start

    http://forum.jigoshop.com/discussions/problems/2875-odd-checkout-issue

    From one other discussion:
    "Just removed /themes/skeleton/checkout/review_order.php and now it works
    fine."

  2. 3 Posted by liamiam on 27 Jul, 2012 12:52 AM

    All,

    thanks for your helpful suggestions.

    I could not find anything specific enough that worked.

    Anyone.

    Please visit https://www.vihtavuori-lapua.com

    put something in the cart and proceed to checkout.

    does it look rightt to you?

  3. Support Staff 4 Posted by ivica on 27 Jul, 2012 05:35 AM

    ivica's Avatar

    Related to Authorize.net / SSL error you have, I found another suggestion:

    "Contact your host to setup (properly) an SSL certificate." Although you
    said you have a valid SSL Cert. installed and properly configured - can
    your host take a look?

  4. 5 Posted by liamiam on 27 Jul, 2012 04:09 PM

    Hi.

    Thank you for your response.

    Hosting support has looked into the issue two times in the last three days.
    Hosting support performed the SSL install - from the very begining and have
    confirmed
    the installation to be correct.

    My seeing the dashboard notice in WP, I enabled the WP debug log.
    I then noticed a message generated from JigoShop and that was what brought
    me to Jigoshop as the culprit.

    Here's the error line again:
    [26-Jul-2012 20:51:18] PHP Warning: session_start() [<a
    href='../../../../forum-sub/discussions/problems/function.session-start/'>function.session-start</a>]: Cannot send
    session cache limiter - headers already sent (output started at
    /home/vihtavuo/public_html/wp-includes/functions.php:2628) in
    /home/vihtavuo/public_html/wp-content/plugins/jigoshop/classes/jigoshop_session.class.php
    on line 20

    I was unable to find any conclusive solution to this warning because I am
    unfamiliar with the Jigoshop plugin (code)

    Maybe you know the answer to this question:
    ----------------------How does one enable the Force SSL option in the
    Authorize.net plugin?
    ----------------------------------------------------------------------------------------------

    When I click the link in the Jigoshop dashboard "enable Force SSL" it
    takes me to a page
    with a single line of text stating "you don't have proper permission" which
    really throws me.

    My permissions are elevated to the highest level possible.

    I have REALLY done everything by the "Jigoshop book"
    without a win on this issue, I can only conclude that the Jigoshop cart
    is still "buggy" and will have to consider abandoning it.

    My client is -livid-

    We gave the cart three months before putting the Gateway into service.

    No one rushed this cart to deployment - we gave it time and lot's of it.

    What's next? can anyone answer to the WP debug log error?

    Can anyone answer the question:
    ----------------------How does one enable the Force SSL option in the
    Authorize.net plugin?
    ----------------------------------------------------------------------------------------------

    and follow up with the reason why highest permission levels are ignored
    when trying to enable the Force SSL Option - making it impossible for the
    Admin User to
    fix the problem that the Jigoshop link in the Jigoshop dash board is
    referring to?

    I have the patience of an Oyster, but my clients usually do not.

    Thanks - in advance.

    -Liam

    The debug log for WP specifically

  5. Support Staff 6 Posted by ivica on 27 Jul, 2012 06:57 PM

    ivica's Avatar

    Sorry for all the problems caused... I repeated the request to developers:
    as they are making final steps for rolling ver. 1.3 (currently Beta), they
    are all currently pretty busy. I hope they will soon be able to look into
    this.

Reply to this discussion

Internal reply

Formatting help or Preview

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.