no add to cart or product + - buttons

david hopkins

23 Aug, 2012 09:56 AM

Hello,
I have been using pagelines framework for a year or two and had no problems,,
I have recently installed your great shop to a few of my clients website, and found that the product pages are not showing the blue add to cart buttons or the + - button to add more products to shop..

i have this problem with a few websites using the page lines framework,

It would be great if some body could help out with this problem

this is one of the websites that i am having problems with..
www.miguellopezfineart.com

here is one of the products
http://www.miguellopezfineart.com/product/beauty-remains-miguel-lopez/

as you will see i have tried to add a button to make it work, but it does not work,,

many thanks in advance

david Hopkins

  1. Support Staff 2 Posted by chriscct7 on 23 Aug, 2012 11:51 AM

    chriscct7's Avatar

    We need a copy of your debug.log and Jigoshop System Info as per this
    Thanks,

    -Chris

  2. 3 Posted by david hopkins on 23 Aug, 2012 12:34 PM

    I am not sure what it is really, i just added some code to the wp config file and then saw that this url is what you might need.

    http://www.miguellopezfineart.com/wp-content/debug.log

    i upgraded the jigoshop this morning and i am using a pagelines framework, that has its own plugin.

  3. 4 Posted by David Hopkins on 23 Aug, 2012 02:32 PM

    Hello Chris,

    Here is the system information.

    Begin System Info

    Multi-site:               No
    SITE_URL:                 http://www.marbellarecords.com
    HOME_URL:                 http://www.marbellarecords.com
    Jigoshop Version:         1.3.1
    WordPress Version:        3.4.1
    Platform:                 Apple 
        Browser Name:             Safari  
    Browser Version:          6.0 
    User Agent String:        Mozilla/5.0 (Macintosh; Intel Ma 
                                  c OS X 10_7_4) AppleWebKit/536.2
                                  5 (KHTML, like Gecko) Version/6.
                                  0 Safari/536.25
    PHP Version:              5.3.8
    MySQL Version:            5.5.19-cll
    Web Server Info:          Apache
    PHP Memory Limit:         64M
    PHP Post Max Size:        8M
    WP_DEBUG:                 Disabled
    Show On Front:            page
    Page On Front:            576
    Page For Posts:           0
    Session:                  Enabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /var/lib/php/session
    Use Cookies:              On
    Use Only Cookies:         On
    UPLOAD_MAX_FILESIZE:      10MB
    POST_MAX_SIZE:            8MB
    WordPress Memory Limit:   32MB
    WP_DEBUG:                 Off
    DISPLAY ERRORS:           N/A
    FSOCKOPEN:                Your server supports fsockopen.
    ACTIVE PLUGINS:
    Contact Form 7: 3.2.1
    Email newsletter: 10.0
    Hotfix: 0.8
    Jigoshop: 1.3.1
    Jigoshop for PageLines: 1.3
    Pagelines Customize: 1.1.1
    WordPress Importer: 0.6
    WP125: 1.4.3
    CURRENT THEME:
    PageLines Framework: 2.2.5
    ### End System Info ###
    
  4. 5 Posted by david Hopkins on 23 Aug, 2012 02:35 PM

    Hello Chris, sorry that was the wrong website,, here it is for miguellopezfineart.com

    Begin System Info

    Multi-site:               No
    SITE_URL:                 http://www.miguellopezfineart.com
    HOME_URL:                 http://www.miguellopezfineart.com
    Jigoshop Version:         1.3.1
    WordPress Version:        3.4.1
    Platform:                 Apple 
        Browser Name:             Safari  
    Browser Version:          6.0 
    User Agent String:        Mozilla/5.0 (Macintosh; Intel Ma 
                                  c OS X 10_7_4) AppleWebKit/536.2
                                  5 (KHTML, like Gecko) Version/6.
                                  0 Safari/536.25
    PHP Version:              5.3.8
    MySQL Version:            5.5.19-cll
    Web Server Info:          Apache
    PHP Memory Limit:         64M
    PHP Post Max Size:        8M
    WP_DEBUG:                 Enabled
    Show On Front:            page
    Page On Front:            1536
    Page For Posts:           0
    Session:                  Enabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /var/lib/php/session
    Use Cookies:              On
    Use Only Cookies:         On
    UPLOAD_MAX_FILESIZE:      10MB
    POST_MAX_SIZE:            8MB
    WordPress Memory Limit:   32MB
    WP_DEBUG:                 On
    DISPLAY ERRORS:           N/A
    FSOCKOPEN:                Your server supports fsockopen.
    ACTIVE PLUGINS:
    Contact Form 7: 3.2.1
    Easy FancyBox: 1.3.4.9
    Google Analytics: 1.0.2
    Jigoshop: 1.3.1
    Jigoshop for PageLines: 1.4.5
    Pagelines Customize: 1.1.1
    Post Types Order: 1.5.4
    qTranslate: 2.5.31
    WordPress Importer: 0.6
    WordPress SEO: 1.2.7
    CURRENT THEME:
    PageLines Framework: 2.2.5
    ### End System Info ###
    
  5. 6 Posted by Stacey on 24 Aug, 2012 05:06 AM

    I am having the same issue. In the above log I do see plugins that arent compatible with Jigoshop. I checked mine but hope I didn't miss any. The link to check is http://forum.jigoshop.com/kb/testings/list-of-wordpress-plugins-non...

    Begin System Info

    Multi-site:               No
    SITE_URL:                 https://virtualstarr.com
    HOME_URL:                 https://virtualstarr.com
    Jigoshop Version:         1.3
    WordPress Version:        3.4.1
    Platform:                 Windows 
        Browser Name:             Internet Explorer  
    Browser Version:          9.0 
    User Agent String:        Mozilla/5.0 (compatible; MSIE 9. 
                                  0; Windows NT 6.1; WOW64; Triden
                                  t/5.0)
    PHP Version:              5.2.17
    MySQL Version:            5.5.23-55
    Web Server Info:          Apache
    PHP Memory Limit:         256M
    PHP Post Max Size:        64M
    WP_DEBUG:                 Disabled
    Show On Front:            page
    Page On Front:            129
    Page For Posts:           2847
    Session:                  Enabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /tmp
    Use Cookies:              On
    Use Only Cookies:         Off
    UPLOAD_MAX_FILESIZE:      64MB
    POST_MAX_SIZE:            64MB
    WordPress Memory Limit:   32MB
    WP_DEBUG:                 Off
    DISPLAY ERRORS:           On (1)
    FSOCKOPEN:                Your server supports fsockopen.
    ACTIVE PLUGINS:
    Akismet: 2.5.6
    All in One SEO Pack: 1.6.14.6
    A to Z Category Navigation Widget: 1.0
    BM Custom Login: 1.6.6
    BulletProof Security: .47.3
    CalculatorPro Calculators: 1.0.6
    CJ Change Howdy: 3.3.1
    Custom Admin Bar: 1.3
    Dynamic Widgets: 1.5.2
    Easy Contact Forms: 1.4
    Editor Extender: 0.2.1
    FlamingText Logo: 1.0.5
    GD Star Rating: 1.9.20
    Global Hide/Remove Admin Bar Plugin: 1.4
    Image Widget: 3.3.4
    Jigoshop: 1.3
    Jigoshop - Store Toolkit: 1.2.2
    Jigoshop Admin Bar Addition: 1.8
    Lightbox Pop: 2.0
    Login Security Solution: 0.21.0
    Mingle Forum: 1.0.33.2
    MO Cache: 2.0
    Newsletter Manager: 1.1.1
    Open external links in a new window: 1.3
    Outerbridge HumanCaptcha: 1.2.1
    Page Links To: 2.7.1
    PayPal Donations: 1.6
    Quick Cache: 111203
    Register IP: 0.1
    Remove "Comments are closed": 1.2
    Remove Dashboard Access for Non-Admins: 0.4
    Rich Text Excerpts: 1.0
    Scroll Top and Bottom: 2.0
    Search Everything: 6.9.4.1
    Search Meter: 2.8
    Simple Pagination: 2.1.3
    Smart 404: 0.5
    Socializer!: 6.0
    Social Media Widget: 2.9.4
    Styles: 0.5.3
    Supreme Google Webfonts: 1.1
    Twenty Eleven Theme Extensions: 1.2
    TwoChop Play: 1.4.5
    Ultimate TinyMCE: 3.0
    Utech Spinning Earth: 1.2
    Visitor Maps and Who's Online: 1.5.8.1
    Wordfence Security: 3.1.4
    WordPress Protection [Security for your Website]: 3.0
    WordPress SEO: 1.2.5
    WordPress Show Password: 1.1
    WP-PageNavi: 2.82
    WP Cart Mailcheck: 1.0.3
    WP Date Remover: 1.0
    WP Hide Dashboard: 2.1
    WP Super FAQ: 0.5.6
    WPtouch: 1.9.42
    WSA Favicon: 1.0
    CURRENT THEME:
    Twenty Eleven Three Menus: 1.2
    ### End System Info ###
    
  6. 7 Posted by Stacey on 24 Aug, 2012 05:31 AM

    I notice that even the tutorial doesn't have the add to cart button in it's example and thats exactly what mines is doing as well. http://forum.jigoshop.com/kb/creating-products/variable-products

  7. 8 Posted by jakedrake on 27 Aug, 2012 05:37 AM

    jakedrake's Avatar

    I'm having the same problem here with the add to cart button and js 1.3.1. I changed my theme to twentyeleven and voila the swinging buttons reappear. Have you all tried that yet? I have been using Restaurant theme by Organic Themes without any trouble on 1.1 and can even downgrade to return the functionality but something must be different in the 131 that doesn't like this theme. If stacey and David can return their add to cart buttons by changing the theme then we may have a starting point.

  8. Support Staff 9 Posted by chriscct7 on 27 Aug, 2012 11:46 AM

    chriscct7's Avatar

    Hi guys,
    This is entirely a theme issue. The demo and the KB images are a little out of date (which we are working on fixing. If switching to another theme fixes the issue, you need to talk with your theme authors. I know these all work on both Twenty Twelve and Freshshop.

    -Chris

  9. 10 Posted by jakedrake on 27 Aug, 2012 06:04 PM

    jakedrake's Avatar

    Not to hijack this thread but I found out what was causing the missing button in my case. I had overridden the jigoshop_variable_add_to_cart function in my functions.php in order to remove the display of the variable attribute name (in my case, "size") next to the variable name. Looks like there are a couple extra lines in JS 1.3.1 addtocart function so I simply copied over the newer function and made the same change to it and now the add to cart button is functional again!

    Gotta tweak some css apparently that has changed in between versions but at least the buttons back. Oh I also had to upgrade my theme to the latest version too.
    Hope this helps anybody else having the same issue.

  10. 11 Posted by Zach Melis on 28 Aug, 2012 06:54 PM

    Well I am having the same problem and I got the theme from a compatible with jigoshop list so that doesn't make a lick of sense to me.

  11. Support Staff 12 Posted by chriscct7 on 28 Aug, 2012 06:57 PM

    chriscct7's Avatar

    If it works in the 2011 theme then it is a theme issue

    -Chris

  12. 13 Posted by Stacey on 29 Aug, 2012 01:15 AM

    Im using a twenty11 child theme and having the issue.

  13. 14 Posted by Zach Melis on 29 Aug, 2012 01:47 PM

    I understand your point Chris however telling me that its just a theme issue does me absolutely no good. Plus if that is the case I am even more upset because the theme I am using is LISTED on the Jigoshop website as compatible with jigoshop when obviously this isn't the case because one of its BASE functions are not working correctly. Now does anybody have and ideas as to how I, and obviously many others based on how many threads exist about this topic, can possibly overcome this issue.

  14. 15 Posted by jakedrake on 29 Aug, 2012 02:02 PM

    jakedrake's Avatar

    Zach, check your functions.php in your theme and make sure you have not overridden any of the jigoshop functions. If you have, then try to find the new version of the function in JS1.3 and move it to your functions.php and make the same changes to it. This is what caused and solved the same issue for me.

    Also check that you haven't over overridden an entire jigoshop template file in your theme folder. Check this link:
    http://forum.jigoshop.com/kb/customize-jigoshop/theming-with-jigoshop

  15. Support Staff 16 Posted by Jeff on 29 Aug, 2012 03:14 PM

    Jeff's Avatar

    Hmm, playing catch up with this ...

    @David Hopkins -- the link you provide seems to be showing an add to cart button. Is this resolved for you?

    If so, you should deactivate your debug log as it is growing in leaps and bounds. ;-)

    (you can just delete this file via FTP and it will start over again as well)

    @Stacey -- the link you provided to the tutorial won't show an add to cart button as nothing has been selected for the variations in that screenshot yet. Once selections are made, then yes, an add to cart button should appear. If that is your problem in that one isn't appearing, provide a link to a product please.

    @Zach Melis -- same for you, provide a link to one of your products that this isn't functioning for please.

    @All -- This functionality all works, certainly. A number of things can come into play for it not working, and I'll take a quick look, perhaps we can spot something.

  16. 17 Posted by Stacey on 29 Aug, 2012 06:41 PM

    Thanks Jigoshop team for looking into this. The link i set up for testing the feature is here: https://virtualstarr.com/product/z-for-testing

  17. Support Staff 18 Posted by Jeff on 30 Aug, 2012 02:00 AM

    Jeff's Avatar

    Stacey, do you have any variable products that work? Is it just this one?

    The pop-up of the add to cart is javascript controlled. You certainly have a lot of other javascript on the site. I can't seem to even select any text on your page.

    It's possible the apostrophe in the attribute names is interfering (Intl'). As a test, remove them from the attributes and lets see what happens.

    Do you have SSL enabled on the site? There are a lot of insecure content errors in the console.

  18. Support Staff 19 Posted by Jeff on 30 Aug, 2012 12:22 PM

    Jeff's Avatar

    Noticed you changed it Stacey. You are getting one javascript error in the console that is concerning. Could you try disabling SSL and trying it then?

    Which version of Jigoshop do you have? Have you upgraded to Jigoshop 1.3.2?

  19. 20 Posted by Zach Melis on 30 Aug, 2012 02:04 PM

    http://www.tekhnedesign.com/BuildingArea5/product/honda-trx-450-r-e... is not working properly.

  20. 21 Posted by Stacey on 31 Aug, 2012 03:25 AM

    I disabled the SSL and still no button. What I mean by this is that I chose not to force SSL on Jigoshop. outside of this I have no idea what to do.

    Jigoshop Version: 1.3.1
    WordPress Version: 3.4.1

Reply to this discussion

Internal reply

Formatting help or Preview

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.