Blank page problem.

multipoint

20 Aug, 2012 08:34 PM

I’ve installed jigoshop on my website. Everything works fine except some blank page problem. First we can not visit the order editing page. If you click any order, nothing can be loaded in the target page. Fortunately we process the orders in another place, so it doesn’t create any trouble. Recently, we upgrade my wordpress, pagelines and jigoshop to the up-to-date version, then the wp-admin/index.php has the blank page problem too. It’s not a big deal, how every is quite annoying. How can I fixed it? Thanks.

  1. Support Staff 2 Posted by ivica on 20 Aug, 2012 08:39 PM

    ivica's Avatar

    Hi! Try to isolate the possible cause(s) of your problem by performing
    Jigoshop "Simple user testing" (
    http://forum.jigoshop.com/kb/testings/simple-user-testing) and posting your
    results + your System Info.

  2. 3 Posted by multipoint on 22 Aug, 2012 06:43 PM

    Hi, here is my system info:

    ### Begin System Info ###
    Multi-site:               No
    SITE_URL:                 http://dev.cwnp.com
    HOME_URL:                 http://dev.cwnp.com
    Jigoshop Version:         1.3.1
    WordPress Version:        3.4.1
    Platform:                 Windows 
        Browser Name:             Chrome  
    Browser Version:          21.0.1180.79 
    User Agent String:        Mozilla/5.0 (Windows NT 6.1) App 
                                  leWebKit/537.1 (KHTML, like Geck
                                  o) Chrome/21.0.1180.79 Safari/53
                                  7.1
    PHP Version:              5.3.3
    MySQL Version:            5.1.61
    Web Server Info:          Apache/2.2.15 (Red Hat)
    PHP Memory Limit:         256M
    PHP Post Max Size:        8M
    WP_DEBUG:                 Disabled
    Show On Front:            page
    Page On Front:            582
    Page For Posts:           0
    Session:                  Enabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /var/lib/php/session
    Use Cookies:              On
    Use Only Cookies:         On
    UPLOAD_MAX_FILESIZE:      70MB
    POST_MAX_SIZE:            8MB
    WordPress Memory Limit:   32MB
    WP_DEBUG:                 Off
    DISPLAY ERRORS:           N/A
    FSOCKOPEN:                Your server supports fsockopen.
    ACTIVE PLUGINS:
    bbPress: 2.1.2
    bbPress for PageLines: 1.0.6
    Jigoshop: 1.3.1
    CURRENT THEME:
    Twenty Eleven: 1.4
    ### End System Info ###
    

    I’ve gone through the simple user testing. I found that if I deactivated all other plug-ins and activated jigoshop only, then we don’t have the blank wp-admin/index.php problem,but the order editing problem still exist.
    When I say blank page, it’s actually not a blank page anymore when I deactivate the other plugins. It shows an server error page:

    The website encountered an error while retrieving http://dev.cwnp.com/wp-admin/post.php?post=61838&action=edit. It may be down for maintenance or configured incorrectly.
    Here are some suggestions:
    Reload this webpage later.
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    If I activate the bbpress plugin, then the wp-admin/index.php has the same problem.
    If I activate the plugin that I create, then the server error pages become blank pages.

  3. 4 Posted by multipoint on 22 Aug, 2012 06:51 PM

    Sorry I forget to turn on the debug option before. I’m reposting the system info here:

    ### Begin System Info ###
    Multi-site:               No
    SITE_URL:                 http://dev.cwnp.com
    HOME_URL:                 http://dev.cwnp.com
    Jigoshop Version:         1.3.1
    WordPress Version:        3.4.1
    Platform:                 Windows 
        Browser Name:             Chrome  
    Browser Version:          21.0.1180.79 
    User Agent String:        Mozilla/5.0 (Windows NT 6.1) App 
                                  leWebKit/537.1 (KHTML, like Geck
                                  o) Chrome/21.0.1180.79 Safari/53
                                  7.1
    PHP Version:              5.3.3
    MySQL Version:            5.1.61
    Web Server Info:          Apache/2.2.15 (Red Hat)
    PHP Memory Limit:         256M
    PHP Post Max Size:        8M
    WP_DEBUG:                 Enabled
    Show On Front:            page
    Page On Front:            582
    Page For Posts:           0
    Session:                  Enabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /var/lib/php/session
    Use Cookies:              On
    Use Only Cookies:         On
    UPLOAD_MAX_FILESIZE:      70MB
    POST_MAX_SIZE:            8MB
    WordPress Memory Limit:   32MB
    WP_DEBUG:                 On
    DISPLAY ERRORS:           N/A
    FSOCKOPEN:                Your server supports fsockopen.
    ACTIVE PLUGINS:
    bbPress: 2.1.2
    bbPress for PageLines: 1.0.6
    Jigoshop: 1.3.1
    CURRENT THEME:
    Twenty Eleven: 1.4
    ### End System Info ###
    

    However, I can’t catch any debug logs.

  4. Support Staff 5 Posted by ivica on 22 Aug, 2012 07:45 PM

    ivica's Avatar

    I’m not sure if this issue isn’t something about your system, I hope that
    developers could have some available time to take a look on this. I’m not
    sure as I’m not convinced that this is a bug.
    However, you can always "push" this process by asking developers directly
    on the Premium Support: http://support.jigoshop.com/.

  5. 6 Posted by multipoint on 22 Aug, 2012 09:14 PM

    I’m the developer of this website. I want to get some help to dig into this problem. Right now I don’t know which direction I should go.

  6. Support Staff 7 Posted by ivica on 22 Aug, 2012 09:17 PM

    ivica's Avatar

    I wish I could give you a hand but I’m user who isn’t Jigoshop developer –
    they are on http://support.jigoshop.com/.

  7. 8 Posted by multipoint on 22 Aug, 2012 09:24 PM

    I can’t visit this page: http://support.jigoshop.com/. Do you know why?

  8. Support Staff 9 Posted by ivica on 22 Aug, 2012 09:35 PM

    ivica's Avatar

    You should first register to be able to Premium Support:
    https://jigoshop.com/support/

  9. 10 Posted by multipoint on 22 Aug, 2012 09:41 PM

    I see. Thanks.

  10. 11 Posted by kimmersnc on 14 Dec, 2012 02:39 AM

    I am having this same problem, I think. When the user clicks on an item to add to cart, it either appears to hang awhile and then I get the “500 internal server error.”…..or the page just reloads and nothing shows up in the cart.

    Where you able to find the cause for yours?

Reply to this discussion

Internal reply

Formatting help or Preview

Attached Files

You can attach files up to 10MB

If you don’t have an account yet, we need to confirm you’re human and not a machine trying to post spam.