'Add to Cart' missing

Karl

09 Nov, 2011 10:10 PM via web

Help!
Loving the plugin (well, up until this morning).
I'm using 0.9.9.3, and have set up products (candles to be exact) with variations (different fragrances). All seemed to be going well, drop down menus, select the fragrance required - but suddenly upon logging in today, I noticed the Add to Cart option has disappeared after selecting the fragrance?

Tried everything and am stumped!

Cheers in advance,

K.

Showing the most recent page of comments. View the first page

  1. Support Staff 32 Posted by Matt on 09 Dec, 2011 07:25 PM

    Matt's Avatar

    Who's Jason? Haha :p

  2. 33 Posted by tdako on 15 Dec, 2011 04:55 PM

    Hi,

    I've just setup a site for a customer and she's using IE9. After the site went live and she tried to place some orders, she also couldn't see the Add to Cart button.

    I've followed all the steps in this thread, removing the console line at 262 and then the one at 171, but still no show.

    Are there any other steps that one might try?

    thanks a lot in advance

  3. Support Staff 34 Posted by Matt on 15 Dec, 2011 05:08 PM

    Matt's Avatar

    Tdako, read post 30 of this thread.

  4. 35 Posted by tdako on 15 Dec, 2011 05:21 PM

    Hi Matt,

    Thanks for the swift reply.
    Actually that is the one I was referring to with the 171. I just double-checked and indeed the two lines I removed and replaced with the two below.

    The lines now read:

    //search for matching variations for given set of attributes
    function find_matching_variations(attributes) {
        var matching = [];
        for(i = 0; i < product_variations.length; i++) {      
            var variation = product_variations[i];  
            if(variations_match(variation.attributes, attributes)) {
                matching.push(variation);
            }
        }
    

    The link a product is here

  5. Support Staff 36 Posted by Matt on 15 Dec, 2011 07:33 PM

    Matt's Avatar

    Add to cart only shows when an option is selected. Is this the impression you're under?

    http://i.imgur.com/MZx16.png

  6. 37 Posted by tdako on 15 Dec, 2011 07:38 PM

    Hi Matt,

    My (sincere) bad. I had also checked at my brother's a while ago and it works fine. My customer is in the US and she was telling me that on her PC it wasn't showing. We had tried deleting the cache etc. Based on that information, I wrote the above. Personally, I work on a Mac and wasn't seeing any issues.

    Thanks again a million for your time and great support.
    T

  7. 38 Posted by Pete on 22 Dec, 2011 12:10 PM

    Hi,

    I have tried everything in this thread and nothing is working. Made the changed to the script.js file but when an attribute is selected on the single product page no add to cart option appears.

  8. 39 Posted by saidseven on 06 Jan, 2012 05:50 AM

    I have tried every fix listed in several of the threads regarding this topic.
    I even tried disabling some plugins and changing my theme. Still no go.

    http://bravelets.com/shop/breast-cancer-awareness-bravelet-2/

    Can someone please help me? I'd gladly give admin access.
    Thanks

  9. 40 Posted by Daniel B on 13 Jan, 2012 04:08 PM

    Hey folks - I've tried all of the above - the first suggestion by Jeff and his amendment and the suggestion by Matt - bottom line for me is that if I have a Variable product I get no Add to Cart button - if I have a Simple product I do have an Add to Cart button. Am I missing something here? Is there not a straightforward way to just have a Variable product? I want T-shirts in multiple sizes or Photos in premium or fine art editions. Somebody please tell me what I'm doing wrong here.

  10. Support Staff 41 Posted by Jeff on 13 Jan, 2012 04:52 PM

    Jeff's Avatar

    I'll assume Jigoshop version 0.9.9.3?

    You might try Matt's manual upgrade instructions and download and upgrade using that link.

    http://forum.jigoshop.com/kb/getting-started/upgrading

    We believe we have this all fixed in the 0.9.9.4 RC2 branch. Let us know ...

  11. 42 Posted by Daniel - Original Spin on 13 Jan, 2012 05:33 PM

    Hi Jeff,

    Thanks - it turns out that re-building all of the products from the ground
    up fixed the problem. Don't know why - perhaps one needs to set up the
    attributes first? Either way, it works now so I'm a happy camper...Cheers!

    db

  12. 43 Posted by saidseven on 25 Jan, 2012 08:35 PM

    Hello Jeff,

    I updated the beta build manually. Per your link. When i click on the system info i still see.... Jigoshop Version 0.9.9.3. Is this ok? Should it say .4?

    I then proceeded to make a new product from scratch.
    http://bravelets.com/shop/fake-product-2/

    The add to cart still disappears on variable products.
    Can you please help. I'm out of options.

    Thanks
    Cedric

  13. 44 Posted by saidseven on 25 Jan, 2012 08:49 PM

    To add to my post above.

    I also tried creating a new attribute first.
    Then creating a new product.

    This is the link i downloaded from...
    http://downloads.wordpress.org/plugin/jigoshop.zip
    not the beta.

    My client is gonna need this active very soon as the site is already live and taking orders. If i sign up for premium support can i get this taken care of asap? Please advise. Thanks.

  14. Support Staff 45 Posted by Jeff on 25 Jan, 2012 09:31 PM

    Jeff's Avatar

    Yes, it should say 0.9.9.4. If it does not, then you probably haven't used the "manual' upgrade instructions?

    Put another way, same but different, use the beta instructions:

    http://forum.jigoshop.com/kb/getting-started/jigoshop-beta

    But yes, it should say 994, and by all accounts ... this is fixed.

  15. Support Staff 46 Posted by Jeff on 25 Jan, 2012 09:33 PM

    Jeff's Avatar

    I'll add as well ... Jigoshop 1.0 is slated for release next Wednesday on Feb 1st. Possibly a day or so later.

  16. 47 Posted by saidseven on 25 Jan, 2012 10:23 PM

    Thanks for the quick response Jeff.

    I installed the beta plugin exactly to directions. It now says .4.
    I went ahead and made a brand new attribute and a brand new product.
    Still doesnt work :(

    http://bravelets.com/shop/fake-product-4/

    Any ideas?

  17. 48 Posted by saidseven on 25 Jan, 2012 10:33 PM

    I noticed something weird going on... When i go back into the product edit page. The attribute set that i selected to apply to that product disappears sometimes. When i reapply it it will add it then i hit update and its gone again. I've tried just about every combination sometimes it will disappear sometimes it wont . But it still never shows on the actual front end page.

  18. 49 Posted by fiona on 27 Jan, 2012 09:17 AM

    Hi,
    has this issue been resolved as i'm haing the same problem
    fiona

  19. 50 Posted by saidseven on 30 Jan, 2012 10:58 PM

    Has anyone had a chance to look at this? I installed wordpress on a new server with 0 plugins but jigoshop and it still doesn't work. Am i better served paying for premium support? I just need it fixed soon. Thanks.

  20. Support Staff 51 Posted by Matt on 30 Jan, 2012 11:49 PM

    Matt's Avatar

    Premium support would definitely get you sorted.

Reply to this discussion

Internal reply

Formatting help or Preview

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.