Please refer to TemplateMonster Support for any issues surrounding TemplateMonster/TemplateTuning Themes – thanks, Jigoshop Team

Sorry, your session has expired. Return to homepage→

masten

22 Jul, 2013 07:44 PM

Hello

I have the ‘Sorry, your session has expired. Return to homepage →’problem happening when I click ‘place order’ in checkout. Sometimes it kicks in half way through completing the form.

There are lots of different answers for this in the forums like:

‘The solution is to add a php.ini file in the admin folder.’

– but what goes in the php.ini file and is that the wordpress admin folder or the jigoshop admin folder? Then some posts say put it on the root folder.

There’s also the thing about setting the php memory limit. I run a vps with WHM and have control of the php memory limit and have set that to 512M in service configuration/memory_limit. Is that the right setting?

I still have the problem after having done that. I also have cookies set to clear on browser close so that’s not the problem.

It would be very helpful to me and others I see on here to get a comprehensive and definitive answer to this recurring problem

I look forward to your reply

Thanks

Masten

  1. 2 Posted by Cristian on 12 Aug, 2013 05:40 PM

    I’m having the same problem.
    I haven’t done any advanced settings but I noticed the session expires when I change the country, state or when I put a zip code on the billing address.

  2. 3 Posted by masten on 20 Aug, 2013 07:42 PM

    Hi Christian

    Yeah I solved this after hours of messing about. For me it was because the wordpress address and site address didn’t match. Because I built it on an ipaddress, the wordpress address was on http://ipaddress/~account and the site address was set to http://domain.com

    When I changed them to be the same it all worked. It was nothing to with php memory limits, or php.ini files – like all the forum posts talk about.

    Hope this helps

    Cheers

    Masten

  3. 4 Posted by Cristian on 27 Aug, 2013 05:53 PM

    Thank you soooo much Masten,
    that was it!
    I spent a lot of hours trying to figured out as well.
    This made my day!

  4. 5 Posted by masten on 06 Sep, 2013 07:08 PM

    No worries mate! Glad to be of help.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

  •   Remove
  • You can attach files up to 10MB

    If you don’t have an account yet, we need to confirm you’re human and not a machine trying to post spam.

    Keyboard shortcuts

    Generic

    ? Show this help
    ESC Blurs the current field

    Comment Form

    r Focus the comment reply box
    ^ + ↩ Submit the comment

    You can use Command ⌘ instead of Control ^ on Mac