Please refer to TemplateMonster Support for any issues surrounding TemplateMonster/TemplateTuning Themes – thanks, Jigoshop Team

PayPal responses

smudger

25 Jun, 2013 11:07 AM

I have only set up a test site so far and using the PayPal Sandbox feature to test with.
I have Variable products set up as Downloadable and all this works well. However at the moment the e-mail from PayPal (sandbox) after a successful purchase doesn't include a download link. I am returned to the 'Thank you' page (no download link). When viewing 'My Account' there is no download link. The Order has been marked as 'Pending' even though the (pretend) purchase was successful. If I change the Order Status to 'Completed' then the 'My Account' page shows the correct download link but I do not know why the orders are only being marked as 'Pending'.
I'm probably being really stupid and missing something very simple but I can't take the site live without knowing how to avoid this. If anyone has any ideas I would be eternally grateful.

Kind regards and many thanks in advance to anyone who might have some clues.

Sorry should've included my System Info...

### Begin System Info ###
Multi-site:               No
SITE_URL:                 http://192.168.0.2:8888
HOME_URL:                 http://192.168.0.2:8888
Jigoshop Version:         1.7.2
WordPress Version:        3.5.2
Platform:                 Apple 
Browser Name:             Firefox  
Browser Version:          21.0 
User Agent String:        Mozilla/5.0 (Macintosh; Intel Ma 
                              c OS X 10.6; rv:21.0) Gecko/2010
                              0101 Firefox/21.0
PHP Version:              5.4.10
MySQL Version:            5.5.29
Web Server Info:          Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/0.9.8x DAV/2 PHP/5.4.10
PHP Memory Limit:         256M
PHP Post Max Size:        32M
WP_DEBUG:                 Disabled
WP Table Prefix:          Length: 3 Status: Acceptable
Show On Front:            page
Page On Front:            34
Page For Posts:           8
Session:                  Enabled
Session Name:             PHPSESSID
Cookie Path:              /
Save Path:                /Applications/MAMP/tmp/php
Use Cookies:              On
Use Only Cookies:         On
UPLOAD_MAX_FILESIZE:      32MB
POST_MAX_SIZE:            32MB
WordPress Memory Limit:   40MB
WP_DEBUG:                 Off
DISPLAY ERRORS:           N/A
FSOCKOPEN:                Your server supports fsockopen.
ACTIVE PLUGINS:
Allow PHP in Posts and Pages: 3.0.4
Jigoshop: 1.7.2
Regenerate Thumbnails: 2.2.4
Secure and Accessible PHP Contact Form: v.2.1WP B20100702
Slider PRO: 3.6
Weaver II Theme Extras: 1.3
CURRENT THEME:
Weaver II: 1.3.8
### End System Info ###
  1. 2 Posted by smudger on 27 Jun, 2013 09:53 AM

    Found the answer to this and it is rather simple as well. Anyone who is interested the answer is (sadly) in the 'Woo Commerce PayPal Documentation'. I wouldn't insult anyone by linking to the answer here but if you take a look and read you'll see what I did.
    Hopefully guys you'll take a wee look and put the same data in Jigoshop Docs.
    Otherwise anyone who's looking at this - the answer is there.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.