Changing the number of "products per row" and "products per page" in Catalog

Sourena

15 Apr, 2013 07:44 PM

I am trying to change the number of "products per row" and "products per page" in catalog by moving the slider in Jigoshop Settings page. But the number does not change there, neither the number of products per page in the website. How can I fix it?

  1. Support Staff 2 Posted by ivica on 15 Apr, 2013 07:47 PM

    ivica's Avatar

    Try changing theme to default one TwentyTen or TwentyEleven to see if it is
    Theme related issue. Also check what did you setup in WordPress menu for
    number of posts per page.

  2. 3 Posted by Sourena on 15 Apr, 2013 08:48 PM

    Number of pages is set to 10. I changed it to 50. But nothing changes. The number of pages is unrelated to "products per row" any way.

    I switched to TwentyEleven. The issue is still there. The slider in the setting page does not work. It is always set to 3 no matter if the slider is changed or not.

  3. Support Staff 4 Posted by ivica on 15 Apr, 2013 08:54 PM

    ivica's Avatar

    I had some similar issue and my Theme was "guilty one". Developers say that
    some plugins could also make certain issues (as usual), did you try to test
    it? BTW, here it is the whole Simple User testings link if you would like
    to try them out:

    It is recommended that you post here your System Info (WordPress Admin
    backend > Jigoshop > System Info) and perform the following initial
    checkings of your web site / web shop (backup your web site and databases
    before starting any of the following steps):

    - *update *your WordPress, Jigoshop plugin (and database - after Jigoshop
    update), Jigoshop extensions, XAMPP/MAMP (if installed on local PC) to the
    latest versions (if not done before)

    - *check your minimum server requirements *for Jigoshop plugin (
    http://forum.jigoshop.com/kb/getting-started/requirements) *
    **
    - deactivate (and uninstall, if needed) caching plugins, if any* (e.g. W3
    Total Cache or others)*

    - empty your browser cache + cookies* (e.g. using keyboard: CTRL + F5)*

    - quit and relaunch you browser / try other (different) browsers */ *try to
    recreate error on another PC*

    - *check the KB list of WordPress plugins not compatible with Jigoshop *(
    http://forum.jigoshop.com/kb/testings/list-of-wordpress-plugins-non-compatible-with-jigoshop
    )

    - *increase web site/WordPress memory *(
    http://forum.jigoshop.com/kb/faq/fatal-error-allowed-memory-size-of-xxxxx-bytes-exhausted-tried-to-allocate-xx-bytes-in-xx)
    and *PHP Post Max size*

    - check your *Jigoshop Extension requirements/documentation* (if the issue
    involves Jigoshop Extension).

    - try to think of *any customizations/changes* made on your web site /
    Jigoshop that could cause you issues in Jigoshop work

    - try to *delete/uninstall Jigoshop core plugin or/and Jigoshop extensions
    and reinstall them again

    *If nothing mentioned helps, in order to try to recreate reported issue,
    please write here detailed description what were you doing (step by step)
    and turn on debug testing option (
    http://forum.jigoshop.com/kb/testings/how-to-turn-on-debug-testing-option).
    Follow Jigoshop **Simple User testing procedure** on below link for
    particular problem (e.g. when you have checkout errors) or the whole
    procedure and post your debug.log file here so the developers can check out
    those errors:

    http://forum.jigoshop.com/kb/testings/simple-user-testing

Reply to this discussion

Internal reply

Formatting help or Preview

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.